I’ve finally found the solution to fix the annoying Android System pop up notification “USB supplying power to attached device” problem on my Google Pixel XL.  This has been one of the worst problems I’ve had since I first bought the phone almost two years ago.  And pretty much the only problem.  Yes, it’s a great phone and I highly recommend getting one.  🙂

For several weeks I kept getting the annoying pop-up notification.  Usually, it would happen when I tried to plug the USB-C charger into the charging port.  Not only would the system message keep coming back again and again, the phone would not charge unless I selected “Charge this device” from the menu.  Once I did that the phone would usually start charging, but many times it would stop charging and the message would return.  It also seemed as if the battery was draining at a faster rate than normal.

Anyway, if you are having the same issue, I’ve found the solution!  At least it worked for me.  Hopefully, it will for you, too!



How to Fix the USB Supplying Power to Attached Device Problem

NOTE: Be sure to power down your phone before proceeding

What You’ll Need:

1 bottle of 91% Isopropyl Alcohol
1 Q-Tip
1 Pushpin, thumbtack or perhaps a toothpick

isopropyl alcohol q-tip to fix google pixel xl

The cause of phone not charging & system message seemed to be due to a dirty charging port on my Google Pixel XL phone.  This may also happen on other Android phones, but not sure.

To clean the charging port, I first blew air into it to dislodge any obvious dirt or lint.  The next step was to use isopropyl alcohol (I used 91% isopropyl alcohol from the local drug store) to clean the contact pins on the charging port.  At first, I started to use an alcohol dipped Q-tip and this worked somewhat but was unable to go too far with it.  I grabbed a push pin off my cork bulletin board in my office and used it to push part of an alcohol-soaked Q-tip deeper into the port to give it a good cleaning.

Once it appeared that the port was clean, I let it dry out for about 5 minutes and powered the phone back on.

With the phone back on, I plugged the USB-C charger into the charging port and the phone charger indicator came on like it normally should and started to charge.  And, guess what.  No more annoying system message!

It has been about a week since I fixed it, and so far the issue hasn’t returned.

 

If you still get the system message you may want to check your USB connection settings for what happens when a USB-C cable is plugged into your phone.

For future reference, the full text of the system message says:

Use USB to:
Charge this device
Supply power (charge the connected device.  Works only with devices that support USB charging.)
Transfer files
Transfer photos (PTP)

I hope this helps you solve your problem.  If you have any suggestions to improve this solution, please leave a comment below.  Good luck!  🙂