SOLVED: Google Pixel – Charging Connected Device via USB Won’t Go Away

Recently my Google Pixel XL keeps showing the system notification that says Android System – Charging Connected Device via USB.

I have also noticed that if I plug my USB-C phone charger in, the phone will not charge if this message is showing.  In order to get my Pixel to start charging, I have to click on this message and then change the USB setting from “Connected device” to “This device”.

If I do this with the phone charger plugged in, the notification will go away and my phone will resume charging.

Once I unplug my phone, at some point this annoying message will show back up.  What is causing this problem?  How can I get it to go away for good?



I suspect the solution is the same as the one I figured out a few months ago in the article SOLVED: USB Supplying Power to Attached Device Pixel XL Phone.

I have a hunch that this is basically the same problem, just a reworded message due to the Android operating system updates since my original post.

If so, the solution should be the same – simply clean the USB-C charging port with Isopropyl alcohol, a Q-Tip, thumbtack, push pin, toothpick or something similar.  Try dislodging any dirt or debris by blowing air into the port.  You can use canned air if you have that around.  See the above mentioned article for detailed instructions.

Here is a screenshot of the USB preferences.  At the top it has the USB logo/icon and underneath it says “USB controlled by”.

Recent Content